aboutsummaryrefslogtreecommitdiff
path: root/lib/Frontend/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Kremenek <kremenek@apple.com>2011-10-29 00:12:39 +0000
committerTed Kremenek <kremenek@apple.com>2011-10-29 00:12:39 +0000
commit7800212ef29be314d55814e8dcc568ff8beed106 (patch)
treec74caa987a0356b0b1342488e5eff047b28d773e /lib/Frontend/CMakeLists.txt
parentfc2eff57d7497578e8f08a5ee520ad3886a51186 (diff)
Start work on SerializedDiagnosticPrinter, a new DiagnosticConsumer that serializes out the diagnostics for a given translation unit to a bit code file. This is a WIP.
The motivation for this new DiagnosticConsumer is to provide a way for tools invoking the compiler to get its diagnostics via a libclang interface, rather than textually parsing the compiler output. This gives us flexibility to change the compiler's textual output, but have a structured data format for clients to use to get the diagnostics via a stable API. I have no tests for this, but llvm-bcanalyzer so far shows that the emitted file is well-formed. More work to follow. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@143259 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Frontend/CMakeLists.txt')
-rw-r--r--lib/Frontend/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Frontend/CMakeLists.txt b/lib/Frontend/CMakeLists.txt
index 90fa91d04d..cbeb69d12b 100644
--- a/lib/Frontend/CMakeLists.txt
+++ b/lib/Frontend/CMakeLists.txt
@@ -27,6 +27,7 @@ add_clang_library(clangFrontend
LogDiagnosticPrinter.cpp
MultiplexConsumer.cpp
PrintPreprocessedOutput.cpp
+ SerializedDiagnosticPrinter.cpp
TextDiagnostic.cpp
TextDiagnosticBuffer.cpp
TextDiagnosticPrinter.cpp