aboutsummaryrefslogtreecommitdiff
path: root/lib/Driver/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2011-12-17 23:10:01 +0000
committerChandler Carruth <chandlerc@gmail.com>2011-12-17 23:10:01 +0000
commit79cbbdc8affe52591f7ee487a789639aa38331ec (patch)
treea636697ce5b6e48e45951b47a5f6c451ebbd427b /lib/Driver/CMakeLists.txt
parent657849c60378b045a9e904f35ece8fd84425a20a (diff)
Split the Windows toolchain definition into its own file. This is
especially nice as the Windows toolchain needs the windows header files, and has lots of platform specific hooks in it. To facilitate the split, hoist a bunch of file-level static helpers into class-level static helpers. Spiff up their doxygen comments while there as they're now more likely to be looked up via docs. Hopefully, this will be followed by further breaking apart of the toolchain definitions. Most of the large and complex ones should likely live on their own. I'm looking at you Darwin. ;] git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@146840 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Driver/CMakeLists.txt')
-rw-r--r--lib/Driver/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Driver/CMakeLists.txt b/lib/Driver/CMakeLists.txt
index ac63a2dfbb..21667e0ee9 100644
--- a/lib/Driver/CMakeLists.txt
+++ b/lib/Driver/CMakeLists.txt
@@ -17,6 +17,7 @@ add_clang_library(clangDriver
Tool.cpp
ToolChain.cpp
ToolChains.cpp
+ WindowsToolChain.cpp
Tools.cpp
Types.cpp
)