aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 25ee2fa..c0d3dd9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,38 @@ else
JANSSON_LIBS=-ljansson
fi
+dnl Find YASM
+has_yasm=false
+AC_PATH_PROG(YASM,[yasm],[true yasm])
+if test "$YASM" = "false" ; then
+ AC_MSG_WARN([yasm is required for the x86_64 SSE2 code, but it was not found])
+fi
+
+AC_MSG_CHECKING([if yasm version is greater than 1.0.1])
+yasmver=`yasm --version | head -1 | cut -d\ -f2`
+yamajor=`echo $yasmver | cut -d. -f1`
+yaminor=`echo $yasmver | cut -d. -f2`
+yamini=`echo $yasmver | cut -d. -f3`
+if test "$yamajor" -ge "1" ; then
+ if test "$yamajor" -eq "1" ; then
+ if test "$yaminor" -ge "0" ; then
+ if test "$yamini" -ge "1"; then
+ has_yasm=true
+ fi
+ fi
+ fi
+else
+has_yasm=false
+fi
+
+if test "x$has_yasm" != "x" ; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+AM_CONDITIONAL([HAS_YASM], [test x$has_yasm = xtrue])
+
PKG_PROG_PKG_CONFIG()
LIBCURL_CHECK_CONFIG(, 7.10.1, ,
@@ -55,6 +87,7 @@ AC_CONFIG_FILES([
Makefile
compat/Makefile
compat/jansson/Makefile
+ x86_64/Makefile
])
AC_OUTPUT