aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@gmail.com>2011-12-29 01:38:05 +0200
committerSiarhei Siamashka <siarhei.siamashka@gmail.com>2011-12-29 06:46:17 +0200
commit7a9481d266b58bd02a7d8033f359ca344cfd65d6 (patch)
treeecc2a56b02db52a0466be9958ab8faee1f0a2b3b /Makefile.am
parenta0139edc7e2c3aa8252405ceff8a23a065965716 (diff)
Use gcc vector extensions for SIMD scrypt key derivation function
The code can be compiled for different architectures from the same source starting with gcc 4.7. But SSE2/Altivec/SPU targets have compatibility wrappers, which also allow the use of older versions of gcc. Two hashes are processed at the same time, so twice bigger scratch buffer is needed (~256K vs. ~128K). Speedup on Cell PPU (32-bit), single thread, 3.2GHz: ~0.58 khash/s -> ~1.79 khash/sec
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8065f2f..5623a59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,8 @@ INCLUDES = $(PTHREAD_FLAGS) -fno-strict-aliasing $(JANSSON_INCLUDES)
bin_PROGRAMS = minerd
minerd_SOURCES = elist.h miner.h compat.h \
- cpu-miner.c util.c scrypt.c sha256-helpers.h
+ cpu-miner.c util.c scrypt.c sha256-helpers.h \
+ scrypt-simd-helpers.h
minerd_LDFLAGS = $(PTHREAD_FLAGS)
minerd_LDADD = @LIBCURL@ @JANSSON_LIBS@ @PTHREAD_LIBS@
minerd_CPPFLAGS = @LIBCURL_CPPFLAGS@