aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@gmail.com>2012-02-21 00:03:44 +0200
committerSiarhei Siamashka <siarhei.siamashka@gmail.com>2012-02-21 00:03:44 +0200
commit3c51c7107674e3fb62734d6fe80405db5484ee5e (patch)
tree7d4484437ba4ea614fcf3cd06847dd12770d3dbb /Makefile.am
parenta62cd79b85c69aea5b980f91d2c563b082b06af0 (diff)
Initial partial conversion to SPU assembly
Only the first loop is converted. The performance is increased up to ~5.97 khash/sec per SPE core. TODO: try to update it to use better data layout and more unrolling from shakti's variant.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 47affe0..b900312 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,10 +22,11 @@ minerd_CPPFLAGS = @LIBCURL_CPPFLAGS@
if HAVE_CELL_SPU
-scrypt-cell-spu.o: scrypt-cell-spu.c sha256-helpers.h \
- scrypt-simd-helpers.h scrypt-cell-spu.h
+scrypt-cell-spu.o: scrypt-cell-spu.c scrypt-cell-spu-asm.S \
+ sha256-helpers.h scrypt-simd-helpers.h \
+ scrypt-cell-spu.h
$(SPU_ELF_GCC) -O3 -fstrict-aliasing -Wall -Wstrict-aliasing \
- -o scrypt-cell-spu.elf scrypt-cell-spu.c
+ -o scrypt-cell-spu.elf scrypt-cell-spu.c scrypt-cell-spu-asm.S
$(EMBEDSPU) scrypt_spu scrypt-cell-spu.elf scrypt-cell-spu.o
minerd_LDADD += scrypt-cell-spu.o @SPE2_LIBS@