aboutsummaryrefslogtreecommitdiff
path: root/src/jtag/hla/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/jtag/hla/Makefile.am')
-rw-r--r--src/jtag/hla/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/jtag/hla/Makefile.am b/src/jtag/hla/Makefile.am
new file mode 100644
index 00000000..4fbc70e9
--- /dev/null
+++ b/src/jtag/hla/Makefile.am
@@ -0,0 +1,23 @@
+include $(top_srcdir)/common.mk
+
+noinst_LTLIBRARIES = libocdhla.la
+
+libocdhla_la_SOURCES = \
+ $(HLFILES)
+
+HLFILES =
+
+if HLADAPTER
+HLFILES += hla_transport.c
+HLFILES += hla_tcl.c
+HLFILES += hla_interface.c
+HLFILES += hla_layout.c
+endif
+
+noinst_HEADERS = \
+ hla_interface.h \
+ hla_layout.h \
+ hla_tcl.h \
+ hla_transport.h
+
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in