aboutsummaryrefslogtreecommitdiff
path: root/src/jtag/aice/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/jtag/aice/Makefile.am')
-rw-r--r--src/jtag/aice/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/jtag/aice/Makefile.am b/src/jtag/aice/Makefile.am
new file mode 100644
index 00000000..38c441e1
--- /dev/null
+++ b/src/jtag/aice/Makefile.am
@@ -0,0 +1,27 @@
+include $(top_srcdir)/common.mk
+
+AM_CPPFLAGS += -I$(top_srcdir)/src/jtag/drivers
+
+noinst_LTLIBRARIES = libocdaice.la
+
+libocdaice_la_SOURCES = \
+ $(AICEFILES)
+
+AICEFILES =
+
+if AICE
+AICEFILES += aice_transport.c
+AICEFILES += aice_interface.c
+AICEFILES += aice_port.c
+AICEFILES += aice_usb.c
+AICEFILES += aice_pipe.c
+endif
+
+noinst_HEADERS = \
+ aice_transport.h \
+ aice_interface.h \
+ aice_port.h \
+ aice_usb.h \
+ aice_pipe.h
+
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in