aboutsummaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2014-10-26 10:51:02 +0300
committerSpencer Oliver <spen@spen-soft.co.uk>2015-03-25 21:31:09 +0000
commitef02b69b14d133b061217a91add5a028a77e86bc (patch)
treeee35c9c7475b9747e2feca35af8659ce44119c3d /src/target/Makefile.am
parent1bc6a81138d549edd86fa4266805b690b34c0ae6 (diff)
drivers/cmsis-dap: port to common SWD framework
Valgrind-tested. Comparison of flashing performance on an FRDM-KL25Z board running mbed CMSIS-DAP variant, 5MHz clock, old driver: wrote 28096 bytes from file demo.elf in 26.833590s (1.023 KiB/s) verified 27264 bytes in 1.754972s (15.171 KiB/s) this implementation: wrote 28096 bytes from file demo.elf in 3.691939s (7.432 KiB/s) verified 27264 bytes in 0.598987s (44.450 KiB/s) Also tested "Keil ULINK-ME CMSIS-DAP" with an STM32F100 target, 5MHz clock, results reading from flash, old driver: dumped 131072 bytes in 98.445305s (1.300 KiB/s) this implementation: dumped 131072 bytes in 8.242686s (15.529 KiB/s) Change-Id: Ic64d3124b1d6cd9dd1016445bb627c71e189ae95 Signed-off-by: Paul Fertser <fercerpav@gmail.com> Reviewed-on: http://openocd.zylin.com/2356 Tested-by: jenkins Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index c5911036..2cec491e 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -93,7 +93,6 @@ ARM_DEBUG_SRC = \
arm_adi_v5.c \
adi_v5_jtag.c \
adi_v5_swd.c \
- adi_v5_cmsis_dap.c \
embeddedice.c \
trace.c \
etb.c \