aboutsummaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorAndreas Fritiofson <andreas.fritiofson@gmail.com>2014-06-18 23:10:45 +0200
committerAndreas Fritiofson <andreas.fritiofson@gmail.com>2014-08-02 09:01:32 +0000
commit91e47f3ab8875176b6f6ac9244562f42f140467d (patch)
tree7d5fa6bbf301f70561a6b105bd4469f2093c1c96 /src/target/Makefile.am
parentf1b04a20dcf6baedbd0f06a38d8748586d48dbb7 (diff)
Fix some problems with the bin2char utility
Don't hardcode the type for the array, just output the array initializer so the includer can choose the type and storage class, zero-terminate at will and so on. Change-Id: I6d5e0710eaaba0a218b3eb32f6569177356f4462 Signed-off-by: Andreas Fritiofson <andreas.fritiofson@gmail.com> Reviewed-on: http://openocd.zylin.com/2176 Tested-by: jenkins Reviewed-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index efbeb33a..bf80c64c 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -16,12 +16,12 @@ EXTRA_DIST = \
startup.tcl \
$(wildcard $(srcdir)/xscale/*)
-DEBUG_HEADER = xscale_debug.h
+DEBUG_HEADER = xscale_debug.inc
BUILT_SOURCES = $(DEBUG_HEADER)
CLEANFILES = $(DEBUG_HEADER)
-$(DEBUG_HEADER): $(BIN2C) $(DEBUG_HANDLER)
- $(BIN2C) < $(DEBUG_HANDLER) xscale_debug_handler > xscale_debug.h
+$(DEBUG_HEADER): $(DEBUG_HANDLER) $(BIN2C)
+ $(BIN2C) < $< > $@ || { rm -f $@; false; }
METASOURCES = AUTO
noinst_LTLIBRARIES = libtarget.la