aboutsummaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorHsiangkai Wang <hsiangkai@gmail.com>2013-02-05 09:34:18 +0800
committerSpencer Oliver <spen@spen-soft.co.uk>2013-06-05 19:27:23 +0000
commitceb402dc9e903d2f3f6bc8125dfed9d82b83d2d1 (patch)
tree30771448f2a2e901163c33947414039ceece2e79 /src/target/Makefile.am
parent8890ce34696d2e6a18eeda4a410724d24ad57360 (diff)
aice: add Andes AICE support
Andes AICE uses USB to transfer packets between OpenOCD and AICE. It uses high-level USB commands to control targets instead of using JTAG signals. I define an interface as aice_port_api_s. It contains all basic operations needed by target-dependent code. Change-Id: I117bc4f938fab2732e44c509ea68b30172d6fdb9 Signed-off-by: Hsiangkai Wang <hsiangkai@gmail.com> Reviewed-on: http://openocd.zylin.com/1256 Tested-by: jenkins Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index fac1e091..8e9dfb6d 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -31,6 +31,7 @@ libtarget_la_SOURCES = \
$(ARM_MISC_SRC) \
$(AVR32_SRC) \
$(MIPS32_SRC) \
+ $(NDS32_SRC) \
avrt.c \
dsp563xx.c \
dsp563xx_once.c \
@@ -107,6 +108,9 @@ MIPS32_SRC = \
mips32_dmaacc.c \
mips_ejtag.c
+NDS32_SRC = \
+ nds32_reg.c
+
noinst_HEADERS = \
algorithm.h \
@@ -162,7 +166,11 @@ noinst_HEADERS = \
avr32_ap7k.h \
avr32_jtag.h \
avr32_mem.h \
- avr32_regs.h
+ avr32_regs.h \
+ nds32.h \
+ nds32_edm.h \
+ nds32_insn.h \
+ nds32_reg.h
ocddatadir = $(pkglibdir)
nobase_dist_ocddata_DATA =