aboutsummaryrefslogtreecommitdiff
path: root/src/jtag/drivers/Makefile.am
diff options
context:
space:
mode:
authorMauro Gamba <maurillo71@gmail.com>2011-11-16 15:01:04 +0100
committerSpencer Oliver <spen@spen-soft.co.uk>2011-11-18 17:00:58 +0000
commitb302344779941f36129f1c09c24c5bbc414c4744 (patch)
tree9662047971852bed425ee82da5b1e039a55f5474 /src/jtag/drivers/Makefile.am
parent88ca3aabfbc512a1701cd76e3ac9683b167e4299 (diff)
libusb-1.0 support
The configuration script check for libusb-1.0 availability first and only if not found check for libusb-0. So if both libraries are installed on the system the build script will use libusb-1.0 It's possible to force compiling with libusb-0 with the --enable-libusb0 switch. If the driver support only libusb0 the script check anly for it. Change-Id: I7eb045d4e2bd553abefad53f3f4023ff46b0f5f6 Signed-off-by: Mauro Gamba <maurillo71@gmail.com> Reviewed-on: http://openocd.zylin.com/33 Tested-by: jenkins Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
Diffstat (limited to 'src/jtag/drivers/Makefile.am')
-rw-r--r--src/jtag/drivers/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/jtag/drivers/Makefile.am b/src/jtag/drivers/Makefile.am
index 408ea810..1f239b7b 100644
--- a/src/jtag/drivers/Makefile.am
+++ b/src/jtag/drivers/Makefile.am
@@ -20,6 +20,16 @@ if USB
DRIVERFILES += usb_common.c
endif
+if USE_LIBUSB1
+DRIVERFILES += libusb1_common.c
+else
+
+if USE_LIBUSB0
+DRIVERFILES += libusb0_common.c
+endif
+
+endif
+
if BITBANG
DRIVERFILES += bitbang.c
endif