aboutsummaryrefslogtreecommitdiff
path: root/src/jtag/drivers/Makefile.am
diff options
context:
space:
mode:
authorOleksij Rempel <o.rempel@pengutronix.de>2018-06-27 14:54:21 +0200
committerMatthias Welwarsky <matthias@welwarsky.de>2019-02-07 07:51:30 +0000
commita1b308abd4b867e9d3127dee5b9c5906bdf24f99 (patch)
treeef12b3cda33e623e1e8e7271176f0ac463d2b3f2 /src/jtag/drivers/Makefile.am
parentdeaf3d264123391d8fe5c4cccbf8fb8852e1be23 (diff)
jtag: drivers: provide initial support for usb path filtering
With this patch drivers will be able to use usb path filtering. The path format is identical to the format provided by linux kernel: bus-port.port.... With this format it should be easier just to copy and paste path found in dmesg. Change-Id: I8bafa6fcb7a66ff68cc961a376f97f4f3dee35aa Signed-off-by: Oleksij Rempel <o.rempel@pengutronix.de> Reviewed-on: http://openocd.zylin.com/4580 Tested-by: jenkins Reviewed-by: Matthias Welwarsky <matthias@welwarsky.de>
Diffstat (limited to 'src/jtag/drivers/Makefile.am')
-rw-r--r--src/jtag/drivers/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/jtag/drivers/Makefile.am b/src/jtag/drivers/Makefile.am
index ccef018b..572cd244 100644
--- a/src/jtag/drivers/Makefile.am
+++ b/src/jtag/drivers/Makefile.am
@@ -19,6 +19,7 @@ DRIVERFILES =
# Standard Driver: common files
DRIVERFILES += %D%/driver.c
+DRIVERFILES += %D%/jtag_usb_common.c
if USE_LIBUSB1
DRIVERFILES += %D%/libusb1_common.c
@@ -166,6 +167,7 @@ endif
DRIVERHEADERS = \
%D%/bitbang.h \
%D%/bitq.h \
+ %D%/jtag_usb_common.h \
%D%/libusb0_common.h \
%D%/libusb1_common.h \
%D%/libusb_common.h \