aboutsummaryrefslogtreecommitdiff
path: root/src/jtag/aice/Makefile.am
diff options
context:
space:
mode:
authorHsiangkai Wang <hsiangkai@gmail.com>2013-02-05 09:34:18 +0800
committerSpencer Oliver <spen@spen-soft.co.uk>2013-06-05 19:27:23 +0000
commitceb402dc9e903d2f3f6bc8125dfed9d82b83d2d1 (patch)
tree30771448f2a2e901163c33947414039ceece2e79 /src/jtag/aice/Makefile.am
parent8890ce34696d2e6a18eeda4a410724d24ad57360 (diff)
aice: add Andes AICE support
Andes AICE uses USB to transfer packets between OpenOCD and AICE. It uses high-level USB commands to control targets instead of using JTAG signals. I define an interface as aice_port_api_s. It contains all basic operations needed by target-dependent code. Change-Id: I117bc4f938fab2732e44c509ea68b30172d6fdb9 Signed-off-by: Hsiangkai Wang <hsiangkai@gmail.com> Reviewed-on: http://openocd.zylin.com/1256 Tested-by: jenkins Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
Diffstat (limited to 'src/jtag/aice/Makefile.am')
-rw-r--r--src/jtag/aice/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/jtag/aice/Makefile.am b/src/jtag/aice/Makefile.am
new file mode 100644
index 00000000..38c441e1
--- /dev/null
+++ b/src/jtag/aice/Makefile.am
@@ -0,0 +1,27 @@
+include $(top_srcdir)/common.mk
+
+AM_CPPFLAGS += -I$(top_srcdir)/src/jtag/drivers
+
+noinst_LTLIBRARIES = libocdaice.la
+
+libocdaice_la_SOURCES = \
+ $(AICEFILES)
+
+AICEFILES =
+
+if AICE
+AICEFILES += aice_transport.c
+AICEFILES += aice_interface.c
+AICEFILES += aice_port.c
+AICEFILES += aice_usb.c
+AICEFILES += aice_pipe.c
+endif
+
+noinst_HEADERS = \
+ aice_transport.h \
+ aice_interface.h \
+ aice_port.h \
+ aice_usb.h \
+ aice_pipe.h
+
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in