aboutsummaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2014-05-11 22:15:55 +0400
committerAndreas Fritiofson <andreas.fritiofson@gmail.com>2014-08-02 09:00:28 +0000
commitf1b04a20dcf6baedbd0f06a38d8748586d48dbb7 (patch)
treee1e55a4334058d337a7345c3709d1c6f52a2503d /src/helper/Makefile.am
parente03eb89cfb7ee7a952bf8536ae1a4e7f2087d766 (diff)
Provide od+sed replacement for the bin2char helper
Using custom build-time tools is always more problematic, especially for cross-compiling. This alternative implementation assumes "od" (IEEE Std 1003.1-2001) and sed are available which should be the case for any reasonably modern system. Change-Id: I0208f475648c78e7dca127ff4bab60d314b2bf53 Signed-off-by: Paul Fertser <fercerpav@gmail.com> Reviewed-on: http://openocd.zylin.com/2139 Tested-by: jenkins Reviewed-by: Fatih Aşıcı <fatih.asici@gmail.com> Reviewed-by: Andreas Fritiofson <andreas.fritiofson@gmail.com>
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 215bbaed..9477267f 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -44,18 +44,9 @@ noinst_HEADERS = \
replacements.h \
fileio.h \
system.h \
- bin2char.c \
+ bin2char.sh \
jim-nvp.h
EXTRA_DIST = startup.tcl
-BIN2C = bin2char$(EXEEXT_FOR_BUILD)
-
-BUILT_SOURCES = $(BIN2C)
-
-$(BIN2C): bin2char.c
- ${CC_FOR_BUILD} ${CFLAGS_FOR_BUILD} $(srcdir)/bin2char.c -o $@
-
-CLEANFILES = bin2char$(EXEEXT_FOR_BUILD)
-
MAINTAINERCLEANFILES = $(srcdir)/Makefile.in