aboutsummaryrefslogtreecommitdiff
path: root/src/flash/nor/Makefile.am
diff options
context:
space:
mode:
authorMahavir Jain <mjain@marvell.com>2014-09-04 15:31:16 +0530
committerSpencer Oliver <spen@spen-soft.co.uk>2014-09-22 19:37:09 +0000
commit447fb25324f1e9112523ef78825f8dadf3c7ddb7 (patch)
treeec1d6e865b01db090c2a65e4600f2ed5ac9f550c /src/flash/nor/Makefile.am
parente921c69e0e96ba5ad58c58f07b68fbb6cff021aa (diff)
flash/nor: add mrvlqspi flash controller driver
This patch adds support for QSPI flash controller driver for Marvell's Wireless Microcontroller platform. For more information please refer, https://origin-www.marvell.com/microcontrollers/wi-fi-microcontroller-platform/ Following things have been tested on 88MC200 (Winbond W25Q80BV flash chip): 1. Flash sector level erase 2. Flash chip erase 3. Flash write in normal SPI mode 4. Flash fill (write and verify) in normal SPI mode Change-Id: If4414ae3f77ff170b84e426a35b66c44590c5e06 Signed-off-by: Mahavir Jain <mjain@marvell.com> Reviewed-on: http://openocd.zylin.com/2280 Tested-by: jenkins Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
Diffstat (limited to 'src/flash/nor/Makefile.am')
-rw-r--r--src/flash/nor/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/flash/nor/Makefile.am b/src/flash/nor/Makefile.am
index 31681473..bae42fd5 100644
--- a/src/flash/nor/Makefile.am
+++ b/src/flash/nor/Makefile.am
@@ -43,7 +43,8 @@ NOR_DRIVERS = \
kinetis.c \
mini51.c \
nuc1x.c \
- nrf51.c
+ nrf51.c \
+ mrvlqspi.c
noinst_HEADERS = \
core.h \