aboutsummaryrefslogtreecommitdiff
path: root/src/flash/nor/Makefile.am
diff options
context:
space:
mode:
authorJeff Ciesielski <jeffciesielski@gmail.com>2015-01-21 18:57:59 -0800
committerFreddie Chopin <freddie.chopin@gmail.com>2015-11-11 12:08:35 +0000
commit33b048d456e24b9944ff2261cf26b05d630bdd41 (patch)
tree595d052232f9a7dc32d8fa0473b06961684931cc /src/flash/nor/Makefile.am
parent42c24acebd23d758c543c9bf2c2b97bdbd083c35 (diff)
flash: New driver for XMC4xxx microcontroller family
This is a complete flash driver for the Infineon XMC4xxx family of microcontrollers, based on the TMS570 driver by Andrey Yurovsky. The driver attempts to discover the particular variant of MCU via a combination of the SCU register (to determine if this is indeed an XMC4xxx part) and the FLASH0_ID register (to determine the variant). If this fails, the driver will not load. The driver has been added to the README and documentation. Tests: * Hardware: XMC4500 (XMC4500_relax), XMC4200 (XMC4200 enterprise) * SWD + JTAG * Binary: 144k, 1M Note: * Flash protect only partly tested. These parts only allow the flash protection registers (UCB) to be written 4 times total, and my devkits have run out of uses (more on the way) Future Work: * User 1/2(permalock) locking support via custom command * In-memory flash loader bootstrap (flashing is rather slow...) Change-Id: I1d3345d5255d8de8dc4175cf987eb4a037a8cf7f Signed-off-by: Jeff Ciesielski <jeffciesielski@gmail.com> Signed-off-by: Andreas Färber <afaerber@suse.de> Reviewed-on: http://openocd.zylin.com/2488 Tested-by: jenkins Reviewed-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'src/flash/nor/Makefile.am')
-rw-r--r--src/flash/nor/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/flash/nor/Makefile.am b/src/flash/nor/Makefile.am
index b065bb07..eabf6f96 100644
--- a/src/flash/nor/Makefile.am
+++ b/src/flash/nor/Makefile.am
@@ -49,7 +49,8 @@ NOR_DRIVERS = \
nrf51.c \
mrvlqspi.c \
psoc4.c \
- sim3x.c
+ sim3x.c \
+ xmc4xxx.c
noinst_HEADERS = \
core.h \