aboutsummaryrefslogtreecommitdiff
path: root/src/flash/nor/Makefile.am
diff options
context:
space:
mode:
authorAndrey Yurovsky <yurovsky@gmail.com>2013-09-19 13:59:09 -0700
committerSpencer Oliver <spen@spen-soft.co.uk>2014-01-09 15:23:15 +0000
commit9cabe333e14435ed9c92bfcf31b1685634ca1acf (patch)
treed4c4d326808b65390cdb7e016004c6493d53f75c /src/flash/nor/Makefile.am
parent67f664a068238b106249bf33a77a67531bbf3b75 (diff)
add support for Atmel SAM4L NOR Flash
This adds a new NOR Flash driver, "at91sam4l", which supports the built-in Flash on Atmel's low-power SAM4L family of Cortex M4 MCUs. Parts and their geometry are detected automatically using the Chip ID and lookup schemes described in document 42023E–SAM–07/2013. Tested on AT91SAM4LC4CA via the SAM4L XPlained Pro development kit. Change-Id: If73499dee92cc8ce231845244ea25c6984f6cecd Signed-off-by: Andrey Yurovsky <yurovsky@gmail.com> Reviewed-on: http://openocd.zylin.com/1639 Tested-by: jenkins Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
Diffstat (limited to 'src/flash/nor/Makefile.am')
-rw-r--r--src/flash/nor/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/flash/nor/Makefile.am b/src/flash/nor/Makefile.am
index 1082b22c..48e6ab22 100644
--- a/src/flash/nor/Makefile.am
+++ b/src/flash/nor/Makefile.am
@@ -10,6 +10,7 @@ libocdflashnor_la_SOURCES = \
NOR_DRIVERS = \
aduc702x.c \
at91sam4.c \
+ at91sam4l.c \
at91sam3.c \
at91sam7.c \
avrf.c \