aboutsummaryrefslogtreecommitdiff
path: root/src/flash/nor/Makefile.am
diff options
context:
space:
mode:
authorGeorge Harris <george@luminairecoffee.com>2012-08-16 17:53:32 -0700
committerFreddie Chopin <freddie.chopin@gmail.com>2012-09-26 16:17:42 +0000
commit516719b6b8ac35c14396f9a0cbdc355be4e45c10 (patch)
tree0d814e03920fe7f1253af49728561ea794f908f6 /src/flash/nor/Makefile.am
parent15e19011eae841ca4688f1a6053a4d76419bf10e (diff)
Added SPIFI flash driver, algorithms, and docs
Added a flash driver designed to allow program/erase of memory-mapped SPI flash chips for LPC43xx/LPC18xx family micros. This driver includes three algorithms - erase, write, and SPIFI peripheral initialization (to allow memory-mapped access after a reset). The driver has been added to the flash driver table (drivers.c), and the OpenOCD documentation has been updated to include the flash driver configuration command. Change-Id: I79f4ff8f1f07de4e5f2fe4f8c23aeb903f868514 Signed-off-by: George Harris <george@luminairecoffee.com> Reviewed-on: http://openocd.zylin.com/783 Tested-by: jenkins Reviewed-by: Aurelien Jacobs <aurel@gnuage.org> Reviewed-by: Freddie Chopin <freddie.chopin@gmail.com>
Diffstat (limited to 'src/flash/nor/Makefile.am')
-rw-r--r--src/flash/nor/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/flash/nor/Makefile.am b/src/flash/nor/Makefile.am
index d26aa203..c344cd01 100644
--- a/src/flash/nor/Makefile.am
+++ b/src/flash/nor/Makefile.am
@@ -19,6 +19,7 @@ NOR_DRIVERS = \
lpc2000.c \
lpc288x.c \
lpc2900.c \
+ lpcspifi.c \
non_cfi.c \
ocl.c \
pic32mx.c \