aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLuca Bruno <lucab@debian.org>2011-07-09 23:44:39 +0200
committerSpencer Oliver <ntfreak@users.sourceforge.net>2011-07-14 10:19:18 +0100
commitf44bde23b9cf6b3868c712b20cf7d11bdb605482 (patch)
treea991b564016950c615e8c2b7cb907b258f158c0d /src/Makefile.am
parent0ea76bc778a1c5c33bf43e2afbcbbfc819764778 (diff)
Do not append git info to version string when building from released tarball
When building official releases from tarball, git commit info is not available in the building environment. Thus, automake should not try to append the git commit to the version string. Signed-off-by: Luca Bruno <lucab@debian.org> Signed-off-by: Spencer Oliver <ntfreak@users.sourceforge.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1e7af9c7..1be24ea2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,10 +45,11 @@ libopenocd_la_CPPFLAGS = -DPKGBLDDATE=\"`date +%F-%R`\"
# guess-rev.sh returns either a repository version ID or "-snapshot"
if RELEASE
libopenocd_la_CPPFLAGS += -DRELSTR=\"\"
+libopenocd_la_CPPFLAGS += -DGITVERSION=\"\"
else
libopenocd_la_CPPFLAGS += -DRELSTR=\"`$(top_srcdir)/guess-rev.sh $(top_srcdir)`\"
-endif
libopenocd_la_CPPFLAGS += -DGITVERSION=\"`cd $(top_srcdir) && git describe`\"
+endif
# add default CPPFLAGS
libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS)