aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMathias K <kesmtp@freenet.de>2013-10-30 16:52:10 +0100
committerSpencer Oliver <spen@spen-soft.co.uk>2013-12-22 20:22:37 +0000
commit23be4e435f8b61c4603bd7822b3fb3c2c46cb16a (patch)
treec751dafdc5bb9b38becf2f574a164a62338a8bd4 /src/Makefile.am
parent0da3f66ed48d29be02af5e18496d383a7f8c66ba (diff)
build: remove hard coded ftdi and usb libraries
This patch remove the hardcoded libraries. Also a check for libftdi1 installations was added. This check fix an issue with gentoo and maybe other systems. Change-Id: Ieff9ec4d66ee0f3e6b22261a10e4cab9f26b6b51 Signed-off-by: Mathias K <kesmtp@freenet.de> Reviewed-on: http://openocd.zylin.com/1759 Tested-by: jenkins Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 3 insertions, 21 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3413ba95..48af21d4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -52,7 +52,7 @@ libopenocd_la_CPPFLAGS += -DGITVERSION=\"`cd $(top_srcdir) && git describe`\"
endif
# add default CPPFLAGS
-libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS)
+libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS) $(LIBFTDI_CFLAGS)
# the library search path.
libopenocd_la_LDFLAGS = $(all_libraries)
@@ -63,25 +63,6 @@ else
MINGWLDADD =
endif
-if FT2232_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-if PRESTO_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-FTDI2232LIB =
-endif
-endif
-
-LIBUSB =
-if USE_LIBUSB1
-LIBUSB += $(LIBUSB1_LIBS)
-endif
-
-if USE_LIBUSB0
-LIBUSB += $(LIBUSB0_LIBS)
-endif
-
libopenocd_la_LIBADD = \
$(top_builddir)/src/xsvf/libxsvf.la \
$(top_builddir)/src/svf/libsvf.la \
@@ -93,7 +74,8 @@ libopenocd_la_LIBADD = \
$(top_builddir)/src/server/libserver.la \
$(top_builddir)/src/rtos/librtos.la \
$(top_builddir)/src/helper/libhelper.la \
- $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
+ $(LIBFTDI_LIBS) $(MINGWLDADD) \
+ $(LIBUSB1_LIBS) $(LIBUSB0_LIBS)
STARTUP_TCL_SRCS = \
$(srcdir)/helper/startup.tcl \