aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSpencer Oliver <ntfreak@users.sourceforge.net>2011-08-16 17:33:19 +0100
committerSpencer Oliver <ntfreak@users.sourceforge.net>2011-08-16 17:33:19 +0100
commit358df39b43b27aede1adac65f5e3627d42622fe3 (patch)
treea71aad092be3bca6a43d6e46c56f1d3522d9d974 /configure.ac
parent54fc164d3a2e3b83f5a91533cac7829f019a14f2 (diff)
build: check buspirate build host
buspirate has never supported building on native windows (mingw). configure will now check this is not the case. Signed-off-by: Spencer Oliver <ntfreak@users.sourceforge.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1bbc9769..b6c04ab4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -567,6 +567,10 @@ case $host in
fi
parport_use_giveio=yes
+ if test x$build_buspirate = xyes; then
+ AC_MSG_ERROR([buspirate currently not supported by MinGW32 hosts])
+ fi
+
CFLAGS="$CFLAGS -D__USE_MINGW_ANSI_STDIO"
AC_DEFINE(IS_MINGW, 1, [1 if building for MinGW.])