aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Fritiofson <andreas.fritiofson@gmail.com>2016-11-06 15:49:35 +0100
committerPaul Fertser <fercerpav@gmail.com>2016-12-08 15:15:27 +0000
commitef4c139ce224e4d3784bcff411604c1908b13da6 (patch)
tree7460d0f8459ced3b4d3aa24c4ec5db078b7e4483 /configure.ac
parent1789445c8283521951543d5a130fbf10b3594705 (diff)
configure: Don't set user variables
CFLAGS is a user variable and shouldn't be set in either configure.ac or Makefile.am because that makes it impossible to override compiler flags at configure or make time. AC_SUBST the default warning flags into AM_CFLAGS instead, which is emitted before CFLAGS on the compiler command line. Do the same thing with a mingw-specific flag as well. Change-Id: I6ac3a3c8b7e0abf6f0e60ea239b549d68ea6d370 Signed-off-by: Andreas Fritiofson <andreas.fritiofson@gmail.com> Reviewed-on: http://openocd.zylin.com/3870 Tested-by: jenkins Reviewed-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e178d451..50585247 100644
--- a/configure.ac
+++ b/configure.ac
@@ -471,7 +471,7 @@ AS_CASE([$host],
AC_MSG_ERROR([buspirate currently not supported by MinGW32 hosts])
])
- CFLAGS="$CFLAGS -D__USE_MINGW_ANSI_STDIO"
+ AC_SUBST([HOST_CPPFLAGS], [-D__USE_MINGW_ANSI_STDIO])
AC_DEFINE([IS_MINGW], [1], [1 if building for MinGW.])
AC_DEFINE([IS_WIN32], [1], [1 if building for Win32.])
@@ -785,7 +785,7 @@ AS_IF([test "x${gcc_werror}" = "xyes"], [
# overide default gcc cflags
AS_IF([test "x$gcc_warnings" = "xyes"], [
- CFLAGS="$CFLAGS $GCC_WARNINGS"
+ AC_SUBST([GCC_WARNINGS], [$GCC_WARNINGS])
])
AC_CONFIG_FILES([