aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSpencer Oliver <spen@spen-soft.co.uk>2012-05-11 09:10:54 +0100
committerSpencer Oliver <spen@spen-soft.co.uk>2012-05-14 09:41:49 +0000
commit0eaa8e7db06416e3781eca58211df1280308a6c6 (patch)
tree518727f0e47b7b111c2870891ad0b0f3fa393aee /configure.ac
parentec5e4bae251e01d2b7681e370a6c5e82a81e5962 (diff)
jtag: add opendous and estick support
Change-Id: I49c25d226f05fdcaca6cbfc35c2ab47e8464abec Signed-off-by: Spencer Oliver <spen@spen-soft.co.uk> Reviewed-on: http://openocd.zylin.com/611 Tested-by: jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7b82be10..4d7b7d75 100644
--- a/configure.ac
+++ b/configure.ac
@@ -478,6 +478,10 @@ AC_ARG_ENABLE([osbdm],
AS_HELP_STRING([--enable-osbdm], [Enable building support for the OSBDM (JTAG only) Programmer]),
[build_osbdm=$enableval], [build_osbdm=no])
+AC_ARG_ENABLE([opendous],
+ AS_HELP_STRING([--enable-opendous], [Enable building support for the estick/opendous JTAG Programmer]),
+ [build_opendous=$enableval], [build_opendous=no])
+
AC_ARG_ENABLE([minidriver_dummy],
AS_HELP_STRING([--enable-minidriver-dummy], [Enable the dummy minidriver.]),
[build_minidriver_dummy=$enableval], [build_minidriver_dummy=no])
@@ -783,6 +787,12 @@ else
AC_DEFINE([BUILD_OSBDM], [0], [0 if you don't want the OSBDM driver.])
fi
+if test $build_opendous = yes; then
+ AC_DEFINE([BUILD_OPENDOUS], [1], [1 if you want the estick/opendous JTAG driver.])
+else
+ AC_DEFINE([BUILD_OPENDOUS], [0], [0 if you don't want the estick/opendous JTAG driver.])
+fi
+
if test "$use_internal_jimtcl" = yes; then
if test -f "$srcdir/jimtcl/configure.ac"; then
AX_CONFIG_SUBDIR_OPTION([jimtcl], [--disable-install-jim])
@@ -1069,7 +1079,9 @@ fi
# Check for libusb1 ported drivers.
build_usb_ng=no
-if test $build_jlink = yes -o $build_stlink = yes -o $build_osbdm = yes; then
+if test $build_jlink = yes -o $build_stlink = yes -o $build_osbdm = yes -o \
+ $build_opendous = yes
+then
build_usb_ng=yes
fi
@@ -1118,6 +1130,7 @@ AM_CONDITIONAL([REMOTE_BITBANG], [test $build_remote_bitbang = yes])
AM_CONDITIONAL([BUSPIRATE], [test $build_buspirate = yes])
AM_CONDITIONAL([STLINK], [test $build_stlink = yes])
AM_CONDITIONAL([OSBDM], [test $build_osbdm = yes])
+AM_CONDITIONAL([OPENDOUS], [test $build_opendous = yes])
AM_CONDITIONAL([USB], [test $build_usb = yes])
AM_CONDITIONAL([USB_NG], [test $build_usb_ng = yes])
AM_CONDITIONAL([USE_LIBUSB0], [test $use_libusb0 = yes])