aboutsummaryrefslogtreecommitdiff
path: root/utils/TableGen/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-03 20:57:36 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-03 20:57:36 +0000
commitd538e249224a91f85bd4297c71b2bfa71113a9ad (patch)
treea0814fc6e53d64a7d02a4e61e77be8620b2c91f2 /utils/TableGen/CMakeLists.txt
parent2dfbb3e9125aa0a66feab7a7638815b57da85968 (diff)
Changes for building Clang and others using LLVM as an external
library. Installs tblgen (required by Clang). Translates handling of user settings and platform-dependant options to its own file, where it can included by another project. Installs the .cmake files required by projects like Clang. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@124816 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/TableGen/CMakeLists.txt')
-rw-r--r--utils/TableGen/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/utils/TableGen/CMakeLists.txt b/utils/TableGen/CMakeLists.txt
index 2b18b12295..5c10996a96 100644
--- a/utils/TableGen/CMakeLists.txt
+++ b/utils/TableGen/CMakeLists.txt
@@ -1,6 +1,8 @@
set(LLVM_REQUIRES_EH 1)
set(LLVM_REQUIRES_RTTI 1)
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${LLVM_TOOLS_BINARY_DIR})
+
add_executable(tblgen
ARMDecoderEmitter.cpp
AsmMatcherEmitter.cpp
@@ -48,3 +50,5 @@ endif( MINGW )
if( LLVM_ENABLE_THREADS AND HAVE_LIBPTHREAD AND NOT BEOS )
target_link_libraries(tblgen pthread)
endif()
+
+install(TARGETS tblgen RUNTIME DESTINATION bin)