aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDanil Malyshev <dmalyshev@accesssoftek.com>2012-05-17 21:07:47 +0000
committerDanil Malyshev <dmalyshev@accesssoftek.com>2012-05-17 21:07:47 +0000
commitbb8cef51dfe7bb59109786a0ca46ad165c39aa38 (patch)
tree47107748cff082496775ef833af69b4cc385cc19 /test/CMakeLists.txt
parent9133783d5483e38b16af6c10df7a8bbe655d3446 (diff)
- Added ExecutionEngine/MCJIT tests
- Added HOST_ARCH to Makefile.config.in The HOST_ARCH will be used by MCJIT tests filter, because MCJIT supported only x86 and ARM architectures now. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@157015 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index b9e73d087b..ebea47d691 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -49,6 +49,9 @@ else()
set(ENABLE_ASSERTIONS "0")
endif()
+set(HOST_OS ${CMAKE_HOST_SYSTEM_NAME})
+set(HOST_ARCH ${CMAKE_HOST_SYSTEM_PROCESSOR})
+
configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.in
${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg