aboutsummaryrefslogtreecommitdiff
path: root/lib/Target/Mips/CMakeLists.txt
diff options
context:
space:
mode:
authorAkira Hatanaka <ahatanaka@mips.com>2012-04-03 02:20:58 +0000
committerAkira Hatanaka <ahatanaka@mips.com>2012-04-03 02:20:58 +0000
commit885020a7a7299c0cfc12f691bc298e0f41d02190 (patch)
tree349647d7856d054e2c63f7f627eb0553ac31ed25 /lib/Target/Mips/CMakeLists.txt
parent5aeda3f07684e555f19813e41b7fc101434cfe64 (diff)
MIPS disassembler support.
Patch by Vladimir Medic. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@153924 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Mips/CMakeLists.txt')
-rw-r--r--lib/Target/Mips/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/Target/Mips/CMakeLists.txt b/lib/Target/Mips/CMakeLists.txt
index 13d17e4e52..0500c5dc38 100644
--- a/lib/Target/Mips/CMakeLists.txt
+++ b/lib/Target/Mips/CMakeLists.txt
@@ -2,12 +2,14 @@ set(LLVM_TARGET_DEFINITIONS Mips.td)
tablegen(LLVM MipsGenRegisterInfo.inc -gen-register-info)
tablegen(LLVM MipsGenInstrInfo.inc -gen-instr-info)
+tablegen(LLVM MipsGenDisassemblerTables.inc -gen-disassembler)
tablegen(LLVM MipsGenCodeEmitter.inc -gen-emitter)
tablegen(LLVM MipsGenMCCodeEmitter.inc -gen-emitter -mc-emitter)
tablegen(LLVM MipsGenAsmWriter.inc -gen-asm-writer)
tablegen(LLVM MipsGenDAGISel.inc -gen-dag-isel)
tablegen(LLVM MipsGenCallingConv.inc -gen-callingconv)
tablegen(LLVM MipsGenSubtargetInfo.inc -gen-subtarget)
+tablegen(LLVM MipsGenEDInfo.inc -gen-enhanced-disassembly-info)
add_public_tablegen_target(MipsCommonTableGen)
add_llvm_target(MipsCodeGen
@@ -32,6 +34,7 @@ add_llvm_target(MipsCodeGen
)
add_subdirectory(InstPrinter)
+add_subdirectory(Disassembler)
add_subdirectory(TargetInfo)
add_subdirectory(MCTargetDesc)
add_subdirectory(AsmParser)