aboutsummaryrefslogtreecommitdiff
path: root/lib/Analysis/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Grosser <grosser@fim.uni-passau.de>2010-10-20 01:54:44 +0000
committerTobias Grosser <grosser@fim.uni-passau.de>2010-10-20 01:54:44 +0000
commit65513605353c7e3ee8be6fc92892f257ad399d92 (patch)
tree5ed1eadcd13601b914a22908e03ef41152586b4f /lib/Analysis/CMakeLists.txt
parent3e26c3c7d4c652811ab1ec5bd0f2a749c372709b (diff)
Add RegionPass support.
A RegionPass is executed like a LoopPass but on the regions detected by the RegionInfo pass instead of the loops detected by the LoopInfo pass. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116905 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Analysis/CMakeLists.txt')
-rw-r--r--lib/Analysis/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Analysis/CMakeLists.txt b/lib/Analysis/CMakeLists.txt
index 5294550514..d69ab59907 100644
--- a/lib/Analysis/CMakeLists.txt
+++ b/lib/Analysis/CMakeLists.txt
@@ -40,6 +40,7 @@ add_llvm_library(LLVMAnalysis
ProfileInfoLoaderPass.cpp
ProfileVerifierPass.cpp
RegionInfo.cpp
+ RegionPass.cpp
RegionPrinter.cpp
ScalarEvolution.cpp
ScalarEvolutionAliasAnalysis.cpp