aboutsummaryrefslogtreecommitdiff
path: root/cmake/modules/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-08-09 03:26:43 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-08-09 03:26:43 +0000
commit6252e987096e5b7154f18cca04d8e1cadc7373da (patch)
treef171e5c5dbf84f898951f78e95abeee8105af992 /cmake/modules/CMakeLists.txt
parentfd2f3e66fe8ba33c6a9cfb144ad0c136120ec37a (diff)
CMake: system for providing llvm-config-like features to the user.
The user can use a cmake function for obtaining the LLVM libraries corresponding to a list of LLVM components. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@110560 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'cmake/modules/CMakeLists.txt')
-rw-r--r--cmake/modules/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/cmake/modules/CMakeLists.txt b/cmake/modules/CMakeLists.txt
new file mode 100644
index 0000000000..03b1e83da2
--- /dev/null
+++ b/cmake/modules/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(llvm_cmake_builddir "${LLVM_BINARY_DIR}/share/llvm/cmake")
+
+configure_file(
+ LLVM.cmake
+ ${llvm_cmake_builddir}/LLVM.cmake)
+
+install(FILES
+ ${llvm_cmake_builddir}/LLVM.cmake
+ LLVMConfig.cmake
+ LLVMLibDeps.cmake
+ DESTINATION share/llvm/cmake)