aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-11-18 23:45:21 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-11-18 23:45:21 +0000
commit4b442836fcb77e6d6b731a6d6bb3f31b36bc8870 (patch)
treed674af3001ee5900365090010c300bb773d3d8ce /CMakeLists.txt
parentc5b795e8ce28076aeb64ac4342b725bceac3607e (diff)
CMake: Option for enabling/disabling threads.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@59565 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ef79b91de..327a6935c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,8 @@ else( MSVC )
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
endif( MSVC )
+option(LLVM_ENABLE_THREADS "Use threads if available." ON)
+
if( LLVM_TARGETS_TO_BUILD STREQUAL "all" )
set( LLVM_TARGETS_TO_BUILD ${LLVM_ALL_TARGETS} )
endif()