aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 258a7aae53..4ace2bc1e7 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -81,9 +81,13 @@ noinst_PROGRAMS = \
$(WLAN_BIN_SENDER) \
$(WLAN_BIN_RECEIVER)
+if HAVE_TESTING
+TESTING_LIBS = libgnunettransporttesting.la
+endif
+
lib_LTLIBRARIES = \
libgnunettransport.la \
- libgnunettransporttesting.la
+ $(TESTING_LIBS)
libgnunettransporttesting_la_SOURCES = \
transport-testing.c transport-testing.h
@@ -308,6 +312,7 @@ libgnunet_plugin_transport_https_server_la_LDFLAGS = \
libgnunet_plugin_transport_https_server_la_CFLAGS = \
$(CFLAGS) -DBUILD_HTTPS
+if HAVE_TESTING
check_PROGRAMS = \
test_transport_testing_startstop \
test_transport_testing_restart \
@@ -368,6 +373,7 @@ check_PROGRAMS = \
$(HTTP_QUOTA_TEST) \
$(HTTPS_QUOTA_TEST) \
$(WLAN_QUOTA_TEST)
+endif
if ENABLE_TEST_RUN
TESTS = \