aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-09-03 14:19:46 +0000
committerChristian Grothoff <christian@grothoff.org>2015-09-03 14:19:46 +0000
commit526a96f0b6eb60899a1eaa2b281b2728980c5ee0 (patch)
treec8aade8e658e7bae319f9c94f80cb517f18ae946 /src/util/Makefile.am
parent8049927717b940abf3af8e697eb381871a3ca3d5 (diff)
-add benchmark for RSA crypto
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index ca3a361aad..90a0717ab4 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -248,6 +248,7 @@ libgnunet_plugin_test_la_LDFLAGS = \
if HAVE_BENCHMARKS
BENCHMARKS = \
perf_crypto_hash \
+ perf_crypto_rsa \
perf_crypto_paillier \
perf_crypto_symmetric \
perf_crypto_asymmetric \
@@ -626,6 +627,11 @@ perf_crypto_hash_SOURCES = \
perf_crypto_hash_LDADD = \
libgnunetutil.la
+perf_crypto_rsa_SOURCES = \
+ perf_crypto_rsa.c
+perf_crypto_rsa_LDADD = \
+ libgnunetutil.la
+
perf_crypto_symmetric_SOURCES = \
perf_crypto_symmetric.c
perf_crypto_symmetric_LDADD = \