aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-09-28 13:22:21 +0000
committerChristian Grothoff <christian@grothoff.org>2015-09-28 13:22:21 +0000
commit2b70eeaf2bce2c777198d91c5a8357c2426540a0 (patch)
treec7bb436fde68f5dbe86fc05d00cb8d9a2b0084ed /src/util/Makefile.am
parentcab1b047ddcac497e14515fc11f097c4aac8ee27 (diff)
add ecc dlog benchmark
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 90a0717ab4..896ef17eba 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -248,6 +248,7 @@ libgnunet_plugin_test_la_LDFLAGS = \
if HAVE_BENCHMARKS
BENCHMARKS = \
perf_crypto_hash \
+ perf_crypto_ecc_dlog \
perf_crypto_rsa \
perf_crypto_paillier \
perf_crypto_symmetric \
@@ -627,6 +628,12 @@ perf_crypto_hash_SOURCES = \
perf_crypto_hash_LDADD = \
libgnunetutil.la
+perf_crypto_ecc_dlog_SOURCES = \
+ perf_crypto_ecc_dlog.c
+perf_crypto_ecc_dlog_LDADD = \
+ libgnunetutil.la \
+ -lgcrypt
+
perf_crypto_rsa_SOURCES = \
perf_crypto_rsa.c
perf_crypto_rsa_LDADD = \