aboutsummaryrefslogtreecommitdiff
path: root/src/social/Makefile.am
diff options
context:
space:
mode:
authorGabor X Toth <*@tg-x.net>2014-07-23 22:01:32 +0000
committerGabor X Toth <*@tg-x.net>2014-07-23 22:01:32 +0000
commitc954405ee75182cdb7d2a2a4a5e4d23e415120e9 (patch)
tree811ffc8be93a50abe014f2ed9ad880b6f4d07f76 /src/social/Makefile.am
parent51d6cd60f93c8adc4d6d44c16beb383ff90e50bf (diff)
social: fix linking
Diffstat (limited to 'src/social/Makefile.am')
-rw-r--r--src/social/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/social/Makefile.am b/src/social/Makefile.am
index 02b1bf823e..a2dfea244a 100644
--- a/src/social/Makefile.am
+++ b/src/social/Makefile.am
@@ -35,7 +35,12 @@ libgnunetsocial_la_LDFLAGS = \
-version-info 0:0:0
libgnunetsocial_la_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/env/libgnunetenv.la
+ $(top_builddir)/src/env/libgnunetenv.la \
+ $(top_builddir)/src/psyc/libgnunetpsycutil.la \
+ $(top_builddir)/src/core/libgnunetcore.la \
+ $(top_builddir)/src/identity/libgnunetidentity.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
bin_PROGRAMS =
@@ -48,11 +53,13 @@ gnunet_service_social_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/psyc/libgnunetpsyc.la \
+ $(top_builddir)/src/psyc/libgnunetpsycutil.la \
$(GN_LIBINTL)
gnunet_service_social_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
- $(top_builddir)/src/psyc/libgnunetpsyc.la
+ $(top_builddir)/src/psyc/libgnunetpsyc.la \
+ $(top_builddir)/src/psyc/libgnunetpsycutil.la
gnunet_service_social_CFLAGS = $(AM_CFLAGS)