aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-06-13 08:05:15 +0000
committerNils Gillmann <ng0@n0.is>2018-06-13 08:05:15 +0000
commit5c7f4f919d2569f49e4223d77000452dd2ec4e97 (patch)
tree8cec76a5dda6b034d1e5b85eee76a43fafd8a4a5 /src/rps/Makefile.am
parent1f7a2dd68d1e6260fad4af042878c0a07d39bc12 (diff)
parent8503c6fa26449228fa691c1dedfe3ca1a8d0b9ba (diff)
Merge branch 'master' of gnunet.org:gnunet
Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index b5f7122683..d477ade929 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -83,17 +83,18 @@ check_PROGRAMS = \
test_rps_churn
endif
+rps_test_src = \
+ test_rps.c \
+ rps-test_util.h rps-test_util.c \
+ gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c
+
ld_rps_test_lib = \
libgnunetrps.la \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/testbed/libgnunettestbed.la \
-lm
-rps_test_src = \
- test_rps.c \
- rps-test_util.h rps-test_util.c \
- gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c
-
if ENABLE_TEST_RUN
AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
TESTS = $(check_PROGRAMS)
@@ -140,10 +141,19 @@ test_rps_seed_big_LDADD = $(ld_rps_test_lib)
test_rps_churn_SOURCES = $(rps_test_src)
test_rps_churn_LDADD = $(ld_rps_test_lib)
-gnunet_rps_profiler_SOURCES = $(rps_test_src)
+gnunet_rps_profiler_SOURCES = \
+ gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
+ rps-test_util.h rps-test_util.c \
+ gnunet-rps-profiler.c
+
+
gnunet_rps_profiler_LDADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
- $(ld_rps_test_lib)
+ libgnunetrps.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ -lm
+
EXTRA_DIST = \
test_rps.conf