aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorbartpolot <bartpolot@140774ce-b5e7-0310-ab8b-a85725594a96>2014-12-05 14:07:11 +0000
committerbartpolot <bartpolot@140774ce-b5e7-0310-ab8b-a85725594a96>2014-12-05 14:07:11 +0000
commit470f80ea55340d3704297c9dcbf33b2878261b3c (patch)
treeb201a08dda53a39a1572a18d8e08d0359896ea74 /src/rps/Makefile.am
parent644150fa7a7306217ad6e01f525060b3f98bec15 (diff)
Import RPS
git-svn-id: https://gnunet.org/svn/gnunet@34478 140774ce-b5e7-0310-ab8b-a85725594a96
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
new file mode 100644
index 0000000000..f6c31b1073
--- /dev/null
+++ b/src/rps/Makefile.am
@@ -0,0 +1,76 @@
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+pkgcfgdir= $(pkgdatadir)/config.d/
+
+libexecdir= $(pkglibdir)/libexec/
+
+pkgcfg_DATA = \
+ rps.conf
+
+bin_PROGRAMS = gnunet-rps
+
+gnunet_rps_SOURCES = gnunet-rps.c
+gnunet_rps_LDADD = \
+ libgnunetrps.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(XLIB) $(GN_LIBINTL)
+
+lib_LTLIBRARIES = libgnunetrps.la
+
+libgnunetrps_la_SOURCES = \
+ rps_api.c rps.h
+libgnunetrps_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL) $(XLIB)
+libgnunetrps_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) $(WINFLAGS) \
+ -version-info 0:0:0
+
+
+libexec_PROGRAMS = \
+ gnunet-service-rps
+
+
+gnunet_service_rps_SOURCES = \
+ gnunet-service-rps.c
+gnunet_service_rps_LDADD = \
+ libgnunetrps.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/cadet/libgnunetcadet.la \
+ $(top_builddir)/src/nse/libgnunetnse.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(LIBGCRYPT_LIBS) \
+ -lm -lgcrypt \
+ $(GN_LIBINTL)
+
+if HAVE_TESTING
+check_PROGRAMS = \
+ test_rps_multipeer
+endif
+
+if ENABLE_TEST_RUN
+AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
+TESTS = $(check_PROGRAMS)
+endif
+
+test_rps_multipeer_SOURCES = \
+ test_rps_multipeer.c
+test_rps_multipeer_LDADD = \
+ libgnunetrps.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ -lm
+
+
+EXTRA_DIST = \
+ test_rps.conf
+