aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorLRN <lrn1986@gmail.com>2013-01-18 04:51:04 +0000
committerLRN <lrn1986@gmail.com>2013-01-18 04:51:04 +0000
commitebe2770d84d53e3d92fd231b87a5c24d7d733688 (patch)
treeaa6dd90d983d5b0ab99ed6ffd4d754ccd60a1400 /src/regex/Makefile.am
parent067addb72efa8194ce1aac227a3581ef6aa85b02 (diff)
Fix regex dependencies
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index 7d7c84dfeb..44654dd7d2 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -31,6 +31,8 @@ libgnunetregex_la_LIBADD = -lm \
$(top_builddir)/src/dht/libgnunetdht.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/regex/libgnunetregexblock.la
+libgnunetregex_la_DEPENDENCIES = \
+ libgnunetregexblock.la
libgnunetregex_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) \
-version-info 1:1:0
@@ -50,10 +52,7 @@ libgnunet_plugin_block_regex_la_LIBADD = \
libgnunet_plugin_block_regex_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
libgnunet_plugin_block_regex_la_DEPENDENCIES = \
- $(top_builddir)/src/regex/libgnunetregexblock.la \
- $(top_builddir)/src/block/libgnunetblock.la \
- $(top_builddir)/src/util/libgnunetutil.la
-
+ libgnunetregexblock.la
if HAVE_MYSQL
noinst_mysql_progs = \