aboutsummaryrefslogtreecommitdiff
path: root/src/hello/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-03-28 15:14:38 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-03-28 15:14:38 +0000
commitb3883971cd31d198dbd768fffb15960dff0352a6 (patch)
tree1803032b911774f57158013eedfc26a3c0fb5462 /src/hello/Makefile.am
parent1fe395444d868f4fd66d44da83cb61a69acc6b66 (diff)
new friend only HELLO type GNUNET_MESSAGE_TYPE_FRIEND_HELLO
Diffstat (limited to 'src/hello/Makefile.am')
-rw-r--r--src/hello/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/hello/Makefile.am b/src/hello/Makefile.am
index fd5a41beab..ef23e8a6e1 100644
--- a/src/hello/Makefile.am
+++ b/src/hello/Makefile.am
@@ -24,7 +24,8 @@ noinst_PROGRAMS = \
gnunet-hello
check_PROGRAMS = \
- test_hello
+ test_hello \
+ test_friend_hello
if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS)
@@ -36,6 +37,11 @@ test_hello_LDADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la
+test_friend_hello_SOURCES = \
+ test_friend_hello.c
+test_friend_hello_LDADD = \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la
gnunet_hello_SOURCES = \
gnunet-hello.c