aboutsummaryrefslogtreecommitdiff
path: root/src/dv/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/dv/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/dv/Makefile.am')
-rw-r--r--src/dv/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/dv/Makefile.am b/src/dv/Makefile.am
index 1b90c2cc85..72e8fa4a85 100644
--- a/src/dv/Makefile.am
+++ b/src/dv/Makefile.am
@@ -65,10 +65,11 @@ libgnunet_plugin_transport_dv_la_LDFLAGS = \
libgnunet_plugin_transport_dv_la_DEPENDENCIES = \
libgnunetdv.la
+if HAVE_TESTING
check_PROGRAMS = \
test_transport_blacklist \
test_transport_dv
-
+endif
if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS)