aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-12-07 22:29:53 +0000
committerChristian Grothoff <christian@grothoff.org>2012-12-07 22:29:53 +0000
commit6304323162321afab21eadf5a0a9433dbeff4e50 (patch)
tree017b5268dfb2ef14b5ed5ef6391ad30cec088cf6 /src/datastore/Makefile.am
parent9366ca95afdc80db816706bcaf6dc25237309d32 (diff)
-implementing heap-based datastore backend
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 1b17fd3ed5..eb97996bd3 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -87,6 +87,7 @@ plugin_LTLIBRARIES = \
$(SQLITE_PLUGIN) \
$(MYSQL_PLUGIN) \
$(POSTGRES_PLUGIN) \
+ libgnunet_plugin_datastore_heap.la \
libgnunet_plugin_datastore_template.la
@@ -100,6 +101,15 @@ libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
+libgnunet_plugin_datastore_heap_la_SOURCES = \
+ plugin_datastore_heap.c
+libgnunet_plugin_datastore_heap_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
+ $(LTLIBINTL)
+libgnunet_plugin_datastore_heap_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+
+
libgnunet_plugin_datastore_mysql_la_SOURCES = \
plugin_datastore_mysql.c
libgnunet_plugin_datastore_mysql_la_LIBADD = \
@@ -132,6 +142,11 @@ libgnunet_plugin_datastore_template_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
check_PROGRAMS = \
+ test_datastore_api_heap \
+ test_datastore_api_management_heap \
+ perf_datastore_api_heap \
+ perf_plugin_datastore_heap \
+ test_plugin_datastore_heap \
$(SQLITE_TESTS) \
$(MYSQL_TESTS) \
$(POSTGRES_TESTS)
@@ -140,6 +155,40 @@ if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS)
endif
+test_datastore_api_heap_SOURCES = \
+ test_datastore_api.c
+test_datastore_api_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/datastore/libgnunetdatastore.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+test_datastore_api_management_heap_SOURCES = \
+ test_datastore_api_management.c
+test_datastore_api_management_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/datastore/libgnunetdatastore.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+perf_datastore_api_heap_SOURCES = \
+ perf_datastore_api.c
+perf_datastore_api_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/datastore/libgnunetdatastore.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+perf_plugin_datastore_heap_SOURCES = \
+ perf_plugin_datastore.c
+perf_plugin_datastore_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+test_plugin_datastore_heap_SOURCES = \
+ test_plugin_datastore.c
+test_plugin_datastore_heap_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+
test_datastore_api_sqlite_SOURCES = \
test_datastore_api.c
test_datastore_api_sqlite_LDADD = \