aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
committerChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
commitd94c5185fcdf47c6a57d3233b946fa7e621f7ad9 (patch)
tree1ded577285183d6457bde8787b9bccaa01f12143 /src/core/Makefile.am
parente184df6030ab5c5374fe3b8a94482ff5a30c1580 (diff)
fixing parallel build, getting rid of useless _DEPENDENCIES declarations
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am20
1 files changed, 9 insertions, 11 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index 5e046f5211..aac1d5fcc6 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -54,10 +54,8 @@ gnunet_service_core_LDADD = \
gnunet_core_SOURCES = \
gnunet-core.c
gnunet_core_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/util/libgnunetutil.la
-gnunet_core_DEPENDENCIES = \
- libgnunetcore.la
if HAVE_TESTING
TESTING_TESTS = test_core_api_send_to_self test_core_api_mq
@@ -80,21 +78,21 @@ endif
test_core_api_SOURCES = \
test_core_api.c
test_core_api_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la
test_core_api_reliability_SOURCES = \
test_core_api_reliability.c
test_core_api_reliability_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la
test_core_api_send_to_self_SOURCES = \
test_core_api_send_to_self.c
test_core_api_send_to_self_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la
@@ -102,7 +100,7 @@ test_core_api_send_to_self_LDADD = \
test_core_api_mq_SOURCES = \
test_core_api_mq.c
test_core_api_mq_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la
@@ -111,13 +109,13 @@ test_core_api_start_only_SOURCES = \
test_core_api_start_only.c
test_core_api_start_only_LDADD = \
$(top_builddir)/src/testing/libgnunettesting.la \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/util/libgnunetutil.la
test_core_quota_compliance_symmetric_SOURCES = \
test_core_quota_compliance.c
test_core_quota_compliance_symmetric_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la
@@ -125,7 +123,7 @@ test_core_quota_compliance_symmetric_LDADD = \
test_core_quota_compliance_asymmetric_send_limited_SOURCES = \
test_core_quota_compliance.c
test_core_quota_compliance_asymmetric_send_limited_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la
@@ -133,7 +131,7 @@ test_core_quota_compliance_asymmetric_send_limited_LDADD = \
test_core_quota_compliance_asymmetric_recv_limited_SOURCES = \
test_core_quota_compliance.c
test_core_quota_compliance_asymmetric_recv_limited_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la \
+ libgnunetcore.la \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la