aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Tölke <toelke@in.tum.de>2011-01-05 15:37:07 +0000
committerPhilipp Tölke <toelke@in.tum.de>2011-01-05 15:37:07 +0000
commit1c930a3459ca5875bc9fc93cf4761f570e02c701 (patch)
tree04914c680f68c94dba91a056dd013904bc9d66cf /src/core/Makefile.am
parent6d3e206b41bee6ed6443c81874c39b872b1f04bc (diff)
test-case for cores send-to-self-feature
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index f4844b8eed..e8d8367179 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -25,7 +25,7 @@ libgnunetcore_la_LDFLAGS = \
bin_PROGRAMS = \
- gnunet-service-core
+ gnunet-service-core test_core_api_send_to_self
gnunet_service_core_SOURCES = \
gnunet-service-core.c
@@ -43,7 +43,8 @@ check_PROGRAMS = \
test_core_api_reliability \
test_core_quota_compliance_symmetric \
test_core_quota_compliance_asymmetric_send_limited \
- test_core_quota_compliance_asymmetric_recv_limited
+ test_core_quota_compliance_asymmetric_recv_limited \
+ test_core_api_send_to_self
if !DISABLE_TEST_RUN
TESTS = $(check_PROGRAMS)
@@ -63,6 +64,13 @@ test_core_api_reliability_LDADD = \
$(top_builddir)/src/transport/libgnunettransport.la \
$(top_builddir)/src/util/libgnunetutil.la
+test_core_api_send_to_self_SOURCES = \
+ test_core_api_send_to_self.c
+test_core_api_send_to_self_LDADD = \
+ $(top_builddir)/src/core/libgnunetcore.la \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
test_core_api_start_only_SOURCES = \
test_core_api_start_only.c
test_core_api_start_only_LDADD = \