aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2013-10-08 16:37:47 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2013-10-08 16:37:47 +0000
commit045bc5be4f794b863b334a41c126c222c5af6c3c (patch)
treef741b930da60ab912bdd3ba0c99ddce38902d735 /src/ats/Makefile.am
parent8929c943f1f57aaf48a1bc3f6edc9939698e688b (diff)
fixes to makefile
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index b86c537249..fd21562132 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -29,18 +29,17 @@ if HAVE_LIBGLPK
GN_MLP_REQUEST_ADD_ADDRESS = test_ats_solver_request_and_add_address_mlp
GN_MLP_REQUEST_DELETE_ADDRESS = test_ats_solver_request_and_delete_address_mlp
GN_MLP_ALTERNATIVE_DELETE_ADDRESS = test_ats_solver_alternative_after_delete_address_mlp
-
endif
lib_LTLIBRARIES = libgnunetats.la
plugin_LTLIBRARIES = \
libgnunet_plugin_ats_proportional.la \
- libgnunet_plugin_ats_mlp.la
+ $(GN_MLP_LIB)
libgnunetats_la_SOURCES = \
ats_api_scheduling.c \
- ats_api_performance.c
+ ats_api_performance.c
libgnunetats_la_LIBADD = \
$(top_builddir)/src/util/libgnunetutil.la \
@@ -135,7 +134,6 @@ libgnunet_plugin_ats_proportional_la_LIBADD = \
$(LTLIBINTL)
if HAVE_LIBGLPK
-endif
libgnunet_plugin_ats_mlp_la_SOURCES = \
libgnunet_plugin_ats_mlp.c
libgnunet_plugin_ats_mlp_la_LIBADD = \
@@ -144,7 +142,7 @@ libgnunet_plugin_ats_mlp_la_LIBADD = \
$(GN_LIBGLPK)
libgnunet_plugin_ats_mlp_la_LDFLAGS = \
$(GN_LIBGLPK)
-
+endif
# scheduling API tests