aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-04-09 23:14:03 +0000
committerChristian Grothoff <christian@grothoff.org>2016-04-09 23:14:03 +0000
commit29e6158507a0758192075ac6ece7ba8e75ddc49a (patch)
treeb91ded48da322f8ba4c9bb0f5504228aa036c2d1 /src/Makefile.am
parent5dfcb058ab5db9ae0c4b147d8a99c64ca0980028 (diff)
small API change: do no longer pass rarely needed GNUNET_SCHEDULER_TaskContext to all scheduler tasks; instead, allow the relatively few tasks that need it to obtain the context via GNUNET_SCHEDULER_get_task_context()
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 38fa423561..f38dd19d36 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,14 +13,9 @@ endif
if HAVE_EXPERIMENTAL
EXP_DIR = \
dv \
- multicast \
- psycutil \
- psycstore \
- psyc \
rps \
- social \
$(CONSENSUS) \
- $(SECRETSHARING)
+ $(SECRETSHARING)
endif
if HAVE_REST
@@ -105,6 +100,11 @@ SUBDIRS = \
exit \
pt \
integration-tests \
+ multicast \
+ psycutil \
+ psycstore \
+ psyc \
+ social \
$(EXP_DIR) \
$(PROVIDER_DIR)