aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-08-14 14:29:19 +0000
committerChristian Grothoff <christian@grothoff.org>2011-08-14 14:29:19 +0000
commitcf5f71ba15c897cd5768ea0dd644d1c9a6a4d4e2 (patch)
treed8561c28f4fe6e9ea54f4bb6dd61328358c34b32 /contrib/Makefile.am
parent330e997d36e21a3a07e9259c38c3d6e13656da21 (diff)
LRN: gnunet janitor -- another killall variant
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index b8dae1bbf5..7ad8e542ac 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -7,7 +7,8 @@ timeout_watchdog_SOURCES = \
endif
noinst_SCRIPTS = \
- gnunet_pyexpect.py
+ gnunet_pyexpect.py \
+ gnunet_janitor.py
dist_pkgdata_DATA = \
gnunet-logo-color.png \
@@ -18,14 +19,14 @@ EXTRA_DIST = \
hostlist.cgi \
hostlist.php \
report.sh \
- gnunet_pyexpect.py.in
+ gnunet_pyexpect.py.in \
+ gnunet_janitor.py.in
do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
-gnunet_pyexpect.py: gnunet_pyexpect.py.in Makefile
- $(do_subst) < $(srcdir)/gnunet_pyexpect.py.in > gnunet_pyexpect.py
- chmod +x gnunet_pyexpect.py
-
+%.py: %.py.in Makefile
+ $(do_subst) < $(srcdir)/$< > $@
+ chmod +x $@
# init_gnunet_redhat \
# init_gnunet_ubuntu \