aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-17 11:53:30 +0000
committerng0 <ng0@infotropique.org>2017-10-17 11:53:30 +0000
commit4a3f7e1ce17b5109e713cdbb37ad85a8852d4723 (patch)
tree371b4f20cc5e07de6ca75c381ee7ebbdcea831cd /contrib/Makefile.am
parent6b2f72df1c7b7317c1c8c52efd74f40c9d30c28a (diff)
contrib/Makefile.am: Use more portable Suffixes Extensions.
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 07cff424c0..ac8b15188b 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -70,7 +70,20 @@ CLEANFILES = \
do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
-%.py: %.py.in Makefile
+# Use SUFFIX Extension rules, they are more portable for every
+# implementation of 'make'.
+# You'll also run into the "'%' is a GNU make extension warning"
+# if you use this:
+#
+#%.py: %.py.in Makefile
+# $(do_subst) < $< > $@
+# chmod +x $@
+#
+# instead of this:
+
+SUFFIXES = .py.in .py
+
+.py.in.py:
$(do_subst) < $< > $@
chmod +x $@