aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-06-04 09:30:57 +0000
committerChristian Grothoff <christian@grothoff.org>2012-06-04 09:30:57 +0000
commit8baa7b150d95a86ad4f59c71216bd1462768928d (patch)
treea9359697eddbf21872a144c6dc8fe67af3822cde /configure.ac
parenta8384a53e6f3f4391d1a45f91bf6b6b4cce32d67 (diff)
#2404, patch 01: configure support for GNU Hurd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a8d61261a..228ff17e02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,6 +162,11 @@ netbsd*)
UNIXONLY=""
funcstocheck=""
;;
+gnu*)
+ AC_DEFINE_UNQUOTED(GNU,1,[This is a GNU system])
+ build_target="gnu"
+ UNIXONLY="#"
+ ;;
*)
AC_MSG_RESULT(Unrecognised OS $host_os)
AC_DEFINE_UNQUOTED(OTHEROS,1,[Some strange OS])
@@ -184,6 +189,7 @@ AM_CONDITIONAL(SOLARIS, test "$build_target" = "solaris")
AM_CONDITIONAL(XFREEBSD, test "$build_target" = "freebsd")
AM_CONDITIONAL(OPENBSD, test "$build_target" = "openbsd")
AM_CONDITIONAL(LINUX, test "$build_target" = "linux")
+AM_CONDITIONAL(GNU, test "$build_target" = "gnu")
AC_MSG_RESULT([$build_target])
AC_SUBST(build_target)