aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-02-21 20:20:33 +0100
committerChristian Grothoff <christian@grothoff.org>2017-02-21 20:20:33 +0100
commit647d88d649c267220feb8b5f53ec3e96359a72fc (patch)
treef0e78fbaed43f946b9e49ab42942303697584fa6 /configure.ac
parent0c7478479c31e75392774b17d850c4325e4ff9a8 (diff)
fix sun_len issue (#4816) by adding test and fixing typo
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b31d0a6c79..7f9cc21971 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1032,6 +1032,16 @@ AC_CHECK_MEMBER([struct sockaddr_in.sin_len],
#include <netinet/in.h>
])
+AC_CHECK_MEMBER([struct sockaddr_un.sun_len],
+ [ AC_DEFINE(HAVE_SOCKADDR_UN_SUN_LEN, 1, [Do we have sockaddr_un.sun_len?])
+ ],
+ [],
+ [
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ ])
+
# Checks for library functions.