aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2014-06-06 12:01:32 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2014-06-06 12:01:32 +0000
commit62e273beeae391a44615e350e48f4ee40f2eab7a (patch)
tree9137da71304165f148468c3135d91a4da9bff967 /configure.ac
parentbdfda4dd17faf721d82bfee411dcaf2777012a9f (diff)
Enable (X)DHT service to be compiled with malicious code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a488dd6eb..3c315afe66 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1209,6 +1209,23 @@ AC_ARG_ENABLE([experimental],
AC_MSG_RESULT($enable_experimental)
AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
+# should malicious code be compiled (should only be used for testing)?
+AC_MSG_CHECKING(whether to compile malicious code)
+AC_ARG_ENABLE([malicious],
+ [AS_HELP_STRING([--enable-malicious], [enable compiling malicious code])],
+ [if test "x$enableval" = "xno"
+ then
+ malicious=0
+ else
+ malicious=1
+ fi],
+ [malicious=0
+ enable_malicious=no])
+AC_MSG_RESULT($enable_malicious)
+AM_CONDITIONAL([ENABLE_MALICIOUS], [$malicious])
+AC_DEFINE_UNQUOTED([ENABLE_MALICIOUS], [$malicious],
+ [enable compilation of malicious code])
+
# should services be started by default when a peer starts? Some services may
# choose to never start by default and it is upto the service/module developer to
# decide it by having "AUTOSTART = NO" instead of "AUTOSTART = @AUTOSTART" in