aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Barksdale <amatus@amat.us>2017-02-20 17:50:55 -0600
committerDavid Barksdale <amatus@amat.us>2017-02-20 17:50:55 -0600
commit24b8e62f2ed410ad5320f7cd1cace020fbaeb179 (patch)
treedb92fbd43b96f84e455a6374b301f5628d27a046 /configure.ac
parent39e6893e4b3bc527b00b684ef804661c4b6588f2 (diff)
Don't put POSTGRESQL_CPPFLAGS in CFLAGS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dc9eabbc4e..b31d0a6c79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -811,13 +811,15 @@ AM_CONDITIONAL(HAVE_SQLITE, test x$sqlite = xtrue)
AC_SUBST(SQLITE_CPPFLAGS)
AC_SUBST(SQLITE_LDFLAGS)
+LDFLAGS=$SAVE_LDFLAGS
+CPPFLAGS=$SAVE_CPPFLAGS
+
# test for postgres
postgres=false
# even running the check for postgres breaks emscripten ...
if test "$taler_only" != yes; then
AX_LIB_POSTGRESQL([])
if test "$found_postgresql" = "yes"; then
- CFLAGS="$CFLAGS $POSTGRESQL_CPPFLAGS"
CPPFLAGS="$CPPFLAGS $POSTGRESQL_CPPFLAGS"
AC_CHECK_HEADERS([libpq-fe.h],
postgres=true)