aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-08-03 19:21:28 +0900
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-08-03 19:21:28 +0900
commit02c92c69ab4193b81ac6f90b52fecb40b94b9208 (patch)
tree0cbbfc249451abd23b238a811f42015df95bbe2a /configure.ac
parentb6755fe23d258a4dc971d8fabc3fae1873e31271 (diff)
parent6bcc73a1cbb1d4a609884762eab1b6de761ad1d9 (diff)
Merge remote-tracking branch 'origin/master' into identity_abe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index bfde625d28..027724774d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1137,45 +1137,6 @@ AC_SUBST(SUDO_BINARY)
AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /])
-# test for nssdir
-AC_MSG_CHECKING(with nssdir)
-AC_ARG_WITH(nssdir,
- [ --with-nssdir=PATH where to install NSS plugins],
- [AC_MSG_RESULT("$with_nssdir")
- case $with_nssdir in
- no)
- NSS_DIR=
- install_nss=0
- ;;
- yes)
- NSS_DIR="/lib"
- install_nss=1
- ;;
- *)
- NSS_DIR=$with_nssdir
- install_nss=1
- ;;
- esac
- ],
- [
-# This test is inappropriate when installation with DESTDIR is
-# run much later and uid will be root when needed. Enabling this
-# code breaks the gnunet.ebuild for gentoo.
-#
-# if test "x$SUDO_BINARY" != "x" -o -w /
-# then
- NSS_DIR="/lib"
- install_nss=1
- AC_MSG_RESULT([yes, to /lib])
-# else
-# NSS_DIR=
-# install_nss=0
-# AC_MSG_RESULT([no])
-# fi
- ])
-AC_SUBST(NSS_DIR)
-AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"])
-
# test for gnunetdns group name
GNUNETDNS_GROUP=gnunetdns
AC_MSG_CHECKING(for gnunetdns group name)
@@ -1816,14 +1777,6 @@ then
AC_MSG_NOTICE([Mac OS X framework build enabled.])
fi
-if test "x$install_nss" = "x0"
-then
- AC_MSG_NOTICE([WARNING: Will not install GNS NSS library])
-else
- AC_MSG_NOTICE([NOTICE: Will install GNS NSS library to $NSS_DIR])
-fi
-
-
AC_MSG_NOTICE([********************************************
Please make sure NOW that you have created a user and group 'gnunet'
and additionally a group 'gnunetdns'. On Debian and Ubuntu GNU/Linux, type: